Android Watch App crashing when unlocking achievement after completing a workout on Bike/Tread

Incident Report for Peloton

Resolved

This issue has been resolved.
Posted Apr 11, 2025 - 10:31 EDT

Monitoring

A fix has been implemented and the latest Android version has been released to members (v.3.48.1).
Posted Apr 09, 2025 - 09:09 EDT

Identified

Members who are working out and specifically using the Android Watch App are experiencing a crash when the member completes a workout and specifically unlocks any achievement in their profile. The team has identified the issue and working to rollout a fix shortly.
Posted Apr 07, 2025 - 21:55 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).