The find friends on Facebook feature is currently unavailable.
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 09:45 EST
Identified
The issue has been identified, and we are working to bring this feature back online.
Posted Oct 16, 2024 - 11:52 EDT