Member Site Login
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 08:42 EST
Monitoring
Our team has implemented a fix for this issue and will continue to monitor any further issues.
Posted Nov 17, 2021 - 16:25 EST
Update
We are continuing to investigate this issue.
Posted Nov 17, 2021 - 11:07 EST
Investigating
Our team is investigating intermittent connection issues to our services. This may affect your ability to log in, view your profile, or take classes. We apologize for any impact this may have on your workout.
Posted Nov 17, 2021 - 11:03 EST
This incident affected: Bike/Tread/App/Row (Member Login, Live Classes, On Demand Classes, Leaderboard, Activation) and Website (Peloton Profile/Workout History (members.onepeloton.com)).