Some members are reporting that they are unable to start a class or are seeing delays in classes starting.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Oct 25, 2025 - 13:42 EDT

Monitoring

Recovery is active, and we are continuing to monitor our dashboards.
Posted Oct 25, 2025 - 12:00 EDT

Investigating

The team is currently investigating the issue.
Posted Oct 25, 2025 - 10:45 EDT
This incident affected: Bike/Tread/App/Row (On Demand Classes).