Inappropriate Follow Requests
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jan 05, 2023 - 12:05 EST
Monitoring
Today, Peloton is taking active action against accounts being intentionally created with inappropriate content, including explicit imagery in their profile picture. These explicit images are a direct violation of our standards and terms of service.

We are actively working to block these accounts and continue to moderate explicit images associated with user profiles. Please do not accept or reply to these follow-requests. To alert us of inappropriate content, please report their username to spam-reports@onepeloton.com.

We apologize to those of you who received these follower requests and were exposed to this content. This is certainly not the community experience we expect for our Peloton Members.
Posted Dec 18, 2022 - 13:17 EST
Investigating
We are currently investigating an issue regarding inappropriate follow requests and content. We apologize for the inconvenience and nature of this content.
If you have inappropriate content to report, you can report a member here: https://peloton.tfaforms.net/4646731
Posted Dec 18, 2022 - 10:30 EST
This incident affected: Website (Peloton Profile/Workout History (members.onepeloton.com)).